IPCop-Forum.de

www.ipcop-forum.de


IPCop-Community
CL-Systems
Home Home   Doku Doku   Links Links   Downloads Downloads
UnIPCop Der (Un)IPCop   IFS IPCop-ForumSpy
CopTime CopTime   Galerie IPCop-Galerie   IPCop Userkarte Userkarte
Aktuelle Zeit: 18.10.2018, 08:06

Alle Zeiten sind UTC+02:00




Ein neues Thema erstellen  Dieses Thema ist gesperrt. Du kannst keine Beiträge editieren oder weitere Antworten erstellen.  [ 1 Beitrag ] 
Autor Nachricht
BeitragVerfasst: 30.06.2010, 03:07 
Offline
Deputy Inspector
Themenstarter
Deputy Inspector
Benutzeravatar

Registriert: 15.11.2006
Beiträge: 71
Wohnort: NRW-DN
Wer Ipcop schon lange kennt der kennt auch noch das SSH Applet MindTerm dass mal Part der Ipcop-Distro in frühen Zeiten war; dann wurde das Applet kommerziell und deswegen aus der Distro entfernt. Jeder kann jedoch das Applet selbst herunterladen zur privaten und nichtkommerziellen Nutzung. Daher habe ich einen Perl Installer gebastelt der - wenn auf der Ipcop gestartet - das aktuelle MindTerm von der Seite des Herstellers herunter lädt, die Nutzungs-Lizenz anzeigt, und - wenn der User dieser zustimmt - dann das Applet zusammen mit einem CGI Script installiert sowie im Menue Services einen Eintrag hinzufügt. MindTerm besitzt mittlerweile auch SCP/SFTP/FTP Plugins - da diese jedoch Zugriff auf das lokale Dateisystem erfordern wird dieses Feature standardmäßig deaktiviert weil das Applet nicht signiert ist. Ich habe jedoch auch ein kleines Perlscript signjar.pl hinzugefügt dass das Signieren erledigt - vorausgesetzt man hat ein Sun JDK (nicht JRE!) installiert.
Wer auf Windows signieren will und kein Perl installiert hat der kann das triviale Perlscript einfach in ein Batchfile umschreiben, oder auch die nötigen Befehle manuell eingeben - siehe auch den Sun Forum-Link im Kopf des Scripts. Vorausgesetzt das Applet ist signiert kann es sowohl PuTTY als auch FileZilla / WinSCP ersetzen, und erlaubt während einer SSH-Session den direkten Aufruf z.B. des SFTP-Plugins ohne erneute Authentifizierung. 8-)
Hier der Link zum AddOn:
http://www.gknw.net/test/ipcop/ipcop-1. ... 1.0.tar.gz
Ich habe das AddOn nur auf 1.9.15 getestet - prinzipiell sollte es zwar auf allen 1.9.x laufen, da jedoch derzeit das Perl-Modul SHA zur Checksum-Prüfung fehlt kann es sein dass das Modul welches ich zum Addon gepackt habe mit älteren 1.9.x nicht läuft. Als Workaround kann man einfach die SHA-Checksum-Prüfung auskommentieren im Installer und darauf vertrauen dass der Download ok ist ...

Feedback welcome!


Nach oben
   
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Dieses Thema ist gesperrt. Du kannst keine Beiträge editieren oder weitere Antworten erstellen.  [ 1 Beitrag ] 

Alle Zeiten sind UTC+02:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.

Gehe zu Forum:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de