IPCop-Forum.de

www.ipcop-forum.de


IPCop-Community
CL-Systems
Home Home   Doku Doku   Links Links   Downloads Downloads
UnIPCop Der (Un)IPCop   IFS IPCop-ForumSpy
CopTime CopTime   Galerie IPCop-Galerie   IPCop Userkarte Userkarte
Aktuelle Zeit: 20.08.2017, 19:16

Alle Zeiten sind UTC+02:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 9 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: T-Com VDSL50 mit T-Entertain (IPTV)
BeitragVerfasst: 16.08.2012, 21:15 
Offline
Deputy Inspector
Themenstarter
Deputy Inspector

Registriert: 17.12.2006
Beiträge: 76
Zunächst meinen Dank an alle IPcop Entwickler und Tester für die nun vorliegende Version 2.0.4.

Ich möchte hier kurz zusammenschreiben, wie ich den Umstieg von 1.4.21 nach 2.0.4 gemacht habe.
Zum einen, damit andere (Änfänger) nicht an dem entwicklungsgeschichtlichen großen Thread verzweifeln, zum anderen, damit der eine oder andere mal drüberschaut und mir sagt, ob das gut oder weniger gut ist, was ich hier gemacht habe.

Ich habe seit mehreren Jahren die Version 1.4.21 mit VDSL50 und dem igmpproxy am laufen. Nun soll der Umstieg auf 2.0.4 und auf neue Hardware (nur Rechner) erfolgen.

Internet Anschluß:
VDSL50 mit T-Entertain (IPTV)

Modem:
Speedport HS300

IPcop:
Super Micro X7SPE-HF-D525 (Intel® Atom™ D525 (Pineview-D) (DMI)
mit insgesamt 6 Interfaces (rot - orange - blau - grün - und über Addon Extra Interfaces unused-1 und unused-2)
"unused-1" wird nicht benutzt, "unused-2" ist GRAY1. Dazu später mehr.

GRÜN: 192.168.100.1
BLAU: 192.168.110.1
ORANGE: 192.168.120.1
GRAY1: 192.168.130.1
ROT: 192.168.150.1

Interfaces, wenn IPcop verbunden ist:
Code:
root@wall01:/etc # ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
2: wan-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:1b:21:b0:04:29 brd ff:ff:ff:ff:ff:ff
    inet 192.168.150.1/24 scope global wan-1
3: dmz-1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:1b:21:b0:04:28 brd ff:ff:ff:ff:ff:ff
    inet 192.168.120.1/24 scope global dmz-1
4: wlan-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:1b:21:b0:04:2b brd ff:ff:ff:ff:ff:ff
    inet 192.168.110.1/24 scope global wlan-1
5: unused-2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:1b:21:b0:04:2a brd ff:ff:ff:ff:ff:ff
    inet 192.168.130.1/24 scope global unused-2
6: unused-1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:25:90:38:2d:6a brd ff:ff:ff:ff:ff:ff
7: lan-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:25:90:38:2d:6b brd ff:ff:ff:ff:ff:ff
    inet 192.168.100.1/24 scope global lan-1
8: wan-1.7@wan-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP
    link/ether 00:1b:21:b0:04:29 brd ff:ff:ff:ff:ff:ff
9: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc pfifo_fast state UNKNOWN qlen 3
    link/ppp
    inet 79.220.114.177 peer 87.186.225.92/32 scope global ppp0
10: wan-1.8@wan-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP
    link/ether 00:1b:21:b0:04:29 brd ff:ff:ff:ff:ff:ff
    inet 217.244.95.178/18 brd 217.244.127.255 scope global wan-1.8


PPPoE Einwahl:
Dank dem aktuellen Stand des Cop ist die VDSL Einwahl kein Thema mehr. Über Netzwerk -> Einwahl -> PPPoE gewählt
Bei Zusätzliche PPPoE-Einstellungen: PPPoE Plugin angeklickt und VLAN-Tag die 7 eingetragen.
Die Authentifizierungsangaben natürlich nicht vergessen ...

In welches Netz sollen die Media Receiver?
Bei meinem alten Cop waren diese in BLAU, nun würde ich dafür gerne das GRAY1 verwenden. Probiere jedoch erst einmal GRÜN und dann BLAU:

hole igmpproxy von hier und installiere ihn mit ./install -i

Anpassung der /etc/igmpproxy.conf für Verwendung in GRÜN:
Code:
##------------------------------------------------------
## Enable Quickleave mode (Sends Leave instantly)
##------------------------------------------------------
quickleave

##------------------------------------------------------
## Configuration for Upstream Interface
##------------------------------------------------------
phyint wan-1.8 upstream  ratelimit 0  threshold 1
        altnet 217.0.119.194/24 #T-COM
        altnet 193.158.35.0/24  #T-COM
        altnet 192.168.100.209 # Receiver

##------------------------------------------------------
## Configuration for Downstream Interface
##------------------------------------------------------
phyint lan-1 downstream  ratelimit 0  threshold 1
        altnet 192.168.100.209 # Receiver

##------------------------------------------------------
## Configuration for lan-1 (Disabled Interface)
##------------------------------------------------------
phyint lo disabled
phyint ppp0 disabled
phyint wan-1 disabled
phyint wan-1.7 disabled
phyint wlan-1 disabled
##phyint lan-1 disabled
phyint dmz-1 disabled
phyint unused-1 disabled
phyint unused-2 disabled


Starten/Stoppen des igmpproxy und iptables setzen/löschen - folgendes in /etc/rc.d/rc.event.local anfügen:
Code:
root@wall01:/etc/rc.d # cat rc.event.local
### # START IP-TV
if [ ${1} == "red" -a ${2} == "up" ]; then
        echo "RED up, Starting IP TV"
        /sbin/modprobe 8021q
        /sbin/vconfig add wan-1 8
        /usr/sbin/dhcpcd wan-1.8

        /sbin/iptables -I CUSTOMFORWARD -s 193.158.35.0/24 -d 224.0.0.0/4 -i wan-1.8 -j ACCEPT
        /sbin/iptables -I CUSTOMINPUT -d 224.0.0.0/4 -j ACCEPT -i wan-1.8
        /sbin/iptables -I CUSTOMFORWARD -s 217.0.119.0/24 -d 224.0.0.0/4 -i wan-1.8 -j ACCEPT
        /sbin/iptables -I CUSTOMFORWARD -d 224.0.0.0/4 -j ACCEPT
        /sbin/iptables -t nat -A CUSTOMPOSTROUTING -o wan-1.8 -d 87.141.128.0/17 -j MASQUERADE

        /usr/sbin/igmpproxy /etc/igmpproxy.conf &
fi
if [ ${1} == "red" -a ${2} == "down" ]; then
        /usr/bin/killall igmpproxy

        /sbin/iptables -D CUSTOMFORWARD -s 193.158.35.0/24 -d 224.0.0.0/4 -i wan-1.8 -j ACCEPT
        /sbin/iptables -D CUSTOMINPUT -d 224.0.0.0/4 -j ACCEPT -i wan-1.8
        /sbin/iptables -D CUSTOMFORWARD -s 217.0.119.0/24 -d 224.0.0.0/4 -i wan-1.8 -j ACCEPT
        /sbin/iptables -D CUSTOMFORWARD -d 224.0.0.0/4 -j ACCEPT
        /sbin/iptables -t nat -A CUSTOMPOSTROUTING -o wan-1.8 -d 87.141.128.0/17 -j MASQUERADE

        /usr/bin/killall dhcpcd
        /sbin/vconfig rem wan-1.8
fi
### END IPTV


wenn ich nur diese Regeln setze wie hier, also:
Code:
### mit diesen Regeln friert der Cop ein
if [ ${1} == "red" -a ${2} == "up" ]; then
        /sbin/modprobe 8021q
        /sbin/vconfig add wan-1 8
        /usr/sbin/dhcpcd wan-1.8

        /sbin/iptables -I CUSTOMFORWARD -s 193.158.35.0/24 -d 224.0.0.0/4 -i wan-1.8 -j ACCEPT
        /sbin/iptables -I CUSTOMINPUT -d 224.0.0.0/4 -j ACCEPT -i wan-1.8
        /sbin/iptables -t nat -A CUSTOMPOSTROUTING -o wan-1.8 -j MASQUERADE

        /usr/sbin/igmpproxy /etc/igmpproxy.conf &
fi
if [ ${1} == "red" -a ${2} == "down" ]; then
        /usr/bin/killall igmpproxy

        /sbin/iptables -D CUSTOMFORWARD -s 193.158.35.0/24 -d 224.0.0.0/4 -i wan-1.8 -j ACCEPT
        /sbin/iptables -D CUSTOMINPUT -d 224.0.0.0/4 -j ACCEPT -i wan-1.8
        /sbin/iptables -t nat -D CUSTOMPOSTROUTING -o wan-1.8 -j MASQUERADE

        /usr/bin/killall dhcpcd
        /sbin/vconfig rem wan-1.8
fi

dann führt dies dazu, daß mein Cop immer langsamer wird und nach einigen Minuten unbedienbar wird. Er reagiert (bei ca.0% CPU Auslastung) auf keine Tastatureingaben, das TV Bild bleibt stehen und ein Bildwechsel erfolgt gefühlt nach 30 Sekunden oder später.

Das wäre IPTV in GRÜN. Programmwechsel in ca. 2-4 Sekunden. Video-on-Demand habe ich noch nie probiert. Keine Info möglich, welche zusätzlichen Anpassungen erforderlich sind bzw. wären.

Nun das ganze nach BLAU verschoben:
- /etc/igmpproxy.conf anpassen
- Media Receiver ins Blaue Netz hängen
- Cop restarten

/etc/igmpproxy.conf:
Code:
##------------------------------------------------------
## Enable Quickleave mode (Sends Leave instantly)
##------------------------------------------------------
quickleave

##------------------------------------------------------
## Configuration for Upstream Interface
##------------------------------------------------------
phyint wan-1.8 upstream  ratelimit 0  threshold 1
        altnet 217.0.119.194/24 #T-COM
        altnet 193.158.35.0/24  #T-COM
        altnet 192.168.110.209 # Receiver

##------------------------------------------------------
## Configuration for Downstream Interface
##------------------------------------------------------
phyint wlan-1 downstream  ratelimit 0  threshold 1
       altnet 192.168.110.209 # Receiver

##------------------------------------------------------
## Configuration for wlan1 (Disabled Interface)
##------------------------------------------------------
phyint lo disabled
phyint ppp0 disabled
phyint wan-1 disabled
phyint wan-1.7 disabled
###phyint wlan-1 disabled
phyint lan-1 disabled
phyint dmz-1 disabled
phyint unused-1 disabled
phyint unused-2 disabled

Damit läuft IPTV in BLAU wie oben in GRÜN

Und nun in GRAY1:
- /etc/igmpproxy.conf anpassen
- Media Receiver ins GRAY1 Netz hängen
- Für GRAY1 DHCP konfigurieren
- Firewall Regeln konfigurieren (*)
- Cop restarten

die /etc/igmpproxy für GRAY1:
Code:
##------------------------------------------------------
## Enable Quickleave mode (Sends Leave instantly)
##------------------------------------------------------
quickleave

##------------------------------------------------------
## Configuration for Upstream Interface
##------------------------------------------------------
phyint wan-1.8 upstream  ratelimit 0  threshold 1
        altnet 217.0.119.194/24 #T-COM
        altnet 193.158.35.0/24  #T-COM
        altnet 192.168.130.209 # Receiver

##------------------------------------------------------
## Configuration for Downstream Interface
##------------------------------------------------------
phyint unused-2 downstream  ratelimit 0  threshold 1
       altnet 192.168.130.209 # Receiver

##------------------------------------------------------
## Configuration for wlan1 (Disabled Interface)
##------------------------------------------------------
phyint lo disabled
phyint ppp0 disabled
phyint wan-1 disabled
phyint wan-1.7 disabled
phyint wlan-1 disabled
phyint lan-1 disabled
phyint dmz-1 disabled
phyint unused-1 disabled


Firewall Regeln konfigurieren (*)
hier verließ mich das Glück, da ich trotz Lektüre des Administrationshandbuches Kapitel 2.6 und den Besonderheiten der Extra Interfaces irgendwas übersehen (nicht verstanden) habe.
Der Receiver bekommt im grauen Netz seine IP. Diese Regel habe ich noch hinbekommen.
Desweiteren habe ich eine Regel angelegt von GRAY1 (any) nach ROT (any) und zunächst alle IPcop Standard Dienste zugelassen.
Ebenso eine Regel von GRAY1 auf den Cop. Der Receiver hat daraufhin nicht mehr reagiert (kein Bild, Beim Booten hängengeblieben).

Also:
welche Regeln müssen wie angelegt werden, damit ich einen Receiver in GRAY1 betreiben kann?

Dank an alle, die mir hier auf die Sprünge helfen ...


Nach oben
   
BeitragVerfasst: 17.08.2012, 00:17 
So ganz erschließt sich mir die Sache mit den unzähligen Anschlüssen nicht und auch den Sinn von igmpproxy sehe ich in diesem Fall nicht.

Ich hatte bis vor ca. 7 Monaten ebenfalls VDSL und zeitweilig den Media-Receiver der Telekom im Einsatz, um ihn für einen Freund auf Herz und Nieren zu testen und bei mir waren diese ganzen Maßnahmen unnötig und das, obwohl der eingesetzte Recher (IPCop) nicht so leistungsfähig gewesen ist, wie dein Cop.

Am Ende hatte ich den Receiver ganz normal in Grün stehen, allerdings mit Priorität auf diesen, also im Rahmen von QoS wurde der Datenverkehr von und zu diesem Receiver bevorzugt behandelt.
Neben dem Receiver hingen noch ein Notebook, mein Arbeitsrechner und ein NAS in Grün und selbst wenn ich am Arbeitsrechner WoW gezockt habe, konnte ich mit dem Receiver problemlos TV schauen.

Das Problem, das bei den letzten beiden von dir geposteten Blöcken aufzutreten scheint, ist ein "Verschlucken" bei der Verarbeitung und damit einhergehend vermutlich eine Überhitzung der CPU.
Von daher würde ich die Kiste mal offen testen und schauen wie das mit der Hitzeentwicklung aussieht.

In den anderen Ausgaben kann ich nix entdecken, was offensichtlich fehlerhaft wäre, aber meine Kenntnisse sind da auch nicht sonderlich umfangreich ;-)


Nach oben
   
BeitragVerfasst: 18.08.2012, 13:20 
Offline
Offizieller Sponsor
Offizieller Sponsor
Benutzeravatar

Registriert: 23.03.2004
Beiträge: 1363
Wohnort: naehe Frankfurt/main
Ohne den IGMP Proxy duerfte der Cop kein IGMP verarbeiten und IPTV funktioniert nicht.
Die Anschluesse...
Bei mir haengt der MR in Gruen...
Es mag aber sicher Umgebungen geben in denen ein eigenes Netz nur fuer den MR sinnvoll ist...
Ich kenne sie zwar bisher nicht... aber...

_________________
Je öfter du mich nach einer Lösung für das Selbe Problem fragst, desto länger brauche ich um sie dir geben zu können.


Zuletzt geändert von Jirik am 25.08.2012, 11:09, insgesamt 1-mal geändert.

Nach oben
   
BeitragVerfasst: 19.08.2012, 02:08 
Hmmm, im Prinzip geb ich dir recht, aber ich hab seinerzeit nichts in der Art installiert, allerdings war das auch nicht mein Cop.
Was ich mich Frage, und das schon seit einiger Zeit, ob es möglich ist, von der Telekom eine zweite IP-Adresse zu bekommen, denn dann könnte man das ganze Problem komplett umgehen, aber mit der eigentlichen Fragestellung hat das natürlich nichts zu tun. :-)


Nach oben
   
BeitragVerfasst: 21.08.2012, 18:02 
Offline
Deputy Inspector
Themenstarter
Deputy Inspector

Registriert: 17.12.2006
Beiträge: 76
Fortsetzung: Die Frage war, was muss wie eingestellt werden, um die Media Receiver (MR) an einem grauen (extra) Interface betreiben zu können.

Die Installation des Extra interface Addons sei natürlich vorausgesetzt. Es werden (in meinem Fall) ein "unused-1" und ein "unused-2" erkannt. Ich verwende aus bestimmten Gründen nur das "unused-2" und nenne es GRAY1.

So muss es unter Firewall -> Schnittstellen auftauchen:
Bild

Dann wird für GRAY1 DHCP eingerichtet:
Bild

Die Firewall Einstellungen sehen dann erst einmal so aus:
Bild

/etc/igmpproxy.conf für Verwendung mit "unused-2" anpassen und zur Aktivierung einfach mal Booten:
Code:
##------------------------------------------------------
## Enable Quickleave mode (Sends Leave instantly)
##------------------------------------------------------
quickleave

##------------------------------------------------------
## Configuration for Upstream Interface
##------------------------------------------------------
phyint wan-1.8 upstream  ratelimit 0  threshold 1
        altnet 217.0.119.194/24 #T-COM
        altnet 193.158.35.0/24  #T-COM
        altnet 192.168.130.201 # Receiver
        altnet 192.168.130.202 # Receiver
        altnet 192.168.130.203 # Receiver

##------------------------------------------------------
## Configuration for Downstream Interface
##------------------------------------------------------
phyint unused-2 downstream  ratelimit 0  threshold 1
       altnet 192.168.130.201 # Receiver
       altnet 192.168.130.202 # Receiver
       altnet 192.168.130.203 # Receiver

##------------------------------------------------------
## Configuration for wlan1 (Disabled Interface)
##------------------------------------------------------
phyint lo disabled
phyint ppp0 disabled
phyint wan-1 disabled
phyint wan-1.7 disabled
phyint wlan-1 disabled
phyint lan-1 disabled
phyint dmz-1 disabled
phyint unused-1 disabled
####phyint unused-2 disabled


Zur Erinnerung:
In diesem Beispiel hat GRAY1 (=unused-2) die 192.168.130.1

Und:
Ein graues Interface ist per Default erst einmal geschlossen, d.h. man muss per FW-Regel alles manuell zulassen, was man braucht.
Was das ist, weiß man, weil man sich auskennt oder ... man wird zum x-ten Mal (zu Recht) daraufhingewiesen, ins Log der Firewall zu schauen und das Handbuch zu lesen.

Kurzfassung:
Bild

Bild

Wie komme ich auf diese Regeln? (ich hoffe, sie stimmen ;-))
Das Firewall-Protokoll öffnen und beobachten, was passiert, wenn man den MR einschaltet.
Jede Zeile, in der GRAY1 auftaucht, ist dabei von Interesse.
Bild

Bild

Das Firewall-Protokoll zeigt also genau an, welcher Dienst gerade von GRAY1 angefordert wird:
DHCP, BOOTPS, BOOTPC, DOMAIN intern
IGMP, HTTP (80), NTP nach extern

Das habe ich so nach und nach eingetragen und immer wieder alles neu gestartet, um zu sehen, ob das nach einem Kaltstart auch wirklich geht. Mit dem oben gezeigten Regeln geht es nun. Die genannten Dienste stehen zunächst mit GRAY1 REJECT im Protokoll und nach Aktivierung der Regel mit GRAY1 ACCEPT.

Der MR möchte gerne noch nach extern auf die Ports 43962 und 47806 zugreifen.
Das habe ich ihm zur Zeit noch verboten, da bei mir trotzdem alles funktioniert.
Ich nutze kein Video on Demand, falls es damit was zu tun haben sollte.

Das war's. Ich entschuldige mich für die eventuell übertriebene Ausführlichkeit oder Seichtigkeit der Ausdrucksweise ...

P.S.: Grobe Fehler bitte melden


Nach oben
   
BeitragVerfasst: 17.09.2012, 13:48 
Offline
Deputy Inspector
Themenstarter
Deputy Inspector

Registriert: 17.12.2006
Beiträge: 76
Nachtrag zu den Firewallregeln

Nach einigen Wochen System beobachten, wundere ich mich doch über diese Einträge im Firewall-Protokoll:

Bild

Hier wird ganz offensichtlich Multicast zurückgewiesen, obwohl ich das doch ziemlich weit oben in diesem Beitrag in der /etc/rc.d/rc.event.local zugelassen habe.
Zitat:
/sbin/iptables -I CUSTOMFORWARD -s 193.158.35.0/24 -d 224.0.0.0/4 -i wan-1.8 -j ACCEPT
/sbin/iptables -I CUSTOMINPUT -d 224.0.0.0/4 -j ACCEPT -i wan-1.8
/sbin/iptables -I CUSTOMFORWARD -s 217.0.119.0/24 -d 224.0.0.0/4 -i wan-1.8 -j ACCEPT
/sbin/iptables -I CUSTOMFORWARD -d 224.0.0.0/4 -j ACCEPT


Trotzdem läuft das IPTV "eigentlich" fehlerfrei. Mir ist gestern nur folgendes aufgefallen. Ich wollte meinen alten MR300 wieder als den Videorecorder aktivieren, um auf alte Aufnahmen dort zurückzugreifen. Nach der Zuweisung sollte ein Restart des Gerätes erfolgen. Der passiert aber nicht. Nur die oben gezeigten Einträge im Protokoll häufen sich. Der MediaReceiver "hängt" sich dann auf. Nach einem Kaltstart weiß er, daß er der Recorder ist, zeigt mir aber die alten Aufnahmen nicht mehr an. Mache ich das Spiel rückwärts, also aktiviere meinen MR303 als Recorder, denn hängt er sich auch auf statt einen Restart zu machen, weiß hinterher aber, daß er der Recorder ist und zeigt alle Aufnahmen an.
Ich weiß definitiv, daß auf dem alten Gerät Aufnahmen sind (habe die noch mit meinem alten Cop sehen können).
Mir scheint, daß ich hier noch bzw. doch irgendwas blockiere, nur was?


Nach oben
   
BeitragVerfasst: 03.01.2013, 21:40 
Offline
IPCop-Entwickler, Site-Moderator, IPCop-Supporter 2006, 2007, 2008 und 2009
IPCop-Entwickler, Site-Moderator, IPCop-Supporter 2006, 2007, 2008 und 2009
Benutzeravatar

Registriert: 26.06.2005
Beiträge: 19149
Wohnort: LDK | Hessen
vectrawally hat geschrieben:
Hier wird ganz offensichtlich Multicast zurückgewiesen, obwohl ich das doch ziemlich weit oben in diesem Beitrag in der /etc/rc.d/rc.event.local zugelassen habe.

Du hast es zugelassen für 'Internet', jedoch nicht für lokale Geräte (192.168.130.1 an unused-2). Keine Ahnung ob das wichtig ist :ka:

_________________
/* Gruß weizen_42 */

Bild
| IPCop Doku | IPCop Galerie | IPCop Uptime | Ärger vermeiden |


Nach oben
   
BeitragVerfasst: 04.05.2017, 08:11 
Offline
Chief Superintendent
Chief Superintendent
Benutzeravatar

Registriert: 28.12.2004
Beiträge: 782
Wohnort: NRW | Meckenheim
Hallo zusammen,

ich habe nun auch seit Anfang des Monats "T-Com Entertain". Anhand des Start-Thread habe ich versucht den Fernseher mit bunten _bewegten_ Bildern zu versorgen ... bisher erfolglos.
Über einen Fehler bin ich gestopert. Ein
Code:
/sbin/vconfig add wan-1 8
/usr/sbin/dhcpcd wan-1.8
in /etc/rc.d/rc.event.local führt zu
Zitat:
07:47:28 dhcpcd[31795] wan-1.8: interface not found or invalid

bzw.
Code:
root@ipcop:~ # /sbin/vconfig add wan-1 8
-bash: /sbin/vconfig: No such file or directory

Weiß jemand was das sein kann?

_________________
| IP-Cop 2.1.9 | KONTRON KTGM45/Flex | Intel Core2Duo P8400 | 2048 MB | 500 GB 3,5 '' HDD | 4* Gigabit NICs (2* Intel 82574L, 1* Intel 82540EM, 1* Intel 82567LM) | Telekom VDSL 50 Mbit flat |
Beam me up Scotty, there is no intelligent life down here!


Nach oben
   
BeitragVerfasst: 29.05.2017, 14:03 
Offline
Deputy Inspector
Themenstarter
Deputy Inspector

Registriert: 17.12.2006
Beiträge: 76
Hallo,

mein ursprünglicher Beitrag ist doch fast fünf Jahre alt und ebenso das IPcop Release von damals. Da hat sich doch inzwischen einiges getan:

/etc/rc.d/rc.event.local
Code:
### # START IP-TV
if [ ${1} == "red" -a ${2} == "up" ]; then
        echo "RED up, Starting IP TV"
        /sbin/modprobe 8021q
        /sbin/ip link add link wan-1 name wan-1.8 type vlan id 8
        /sbin/ip link set wan-1.8 up
        /usr/sbin/dhcpcd wan-1.8

        /sbin/iptables -I CUSTOMFORWARD -s 193.158.35.0/24 -d 224.0.0.0/4 -i wan-1.8 -j ACCEPT
        /sbin/iptables -I CUSTOMINPUT -d 224.0.0.0/4 -j ACCEPT -i wan-1.8
        /sbin/iptables -I CUSTOMFORWARD -s 217.0.119.0/24 -d 224.0.0.0/4 -i wan-1.8 -j ACCEPT
        /sbin/iptables -I CUSTOMFORWARD -d 224.0.0.0/4 -j ACCEPT
        /sbin/iptables -t nat -A CUSTOMPOSTROUTING -o wan-1.8 -d 87.141.128.0/17 -j MASQUERADE

        sleep 22
        /usr/sbin/igmpproxy /etc/igmpproxy.conf &
fi
if [ ${1} == "red" -a ${2} == "down" ]; then
        /usr/bin/killall igmpproxy

        /sbin/iptables -D CUSTOMFORWARD -s 193.158.35.0/24 -d 224.0.0.0/4 -i wan-1.8 -j ACCEPT
        /sbin/iptables -D CUSTOMINPUT -d 224.0.0.0/4 -j ACCEPT -i wan-1.8
        /sbin/iptables -D CUSTOMFORWARD -s 217.0.119.0/24 -d 224.0.0.0/4 -i wan-1.8 -j ACCEPT
        /sbin/iptables -D CUSTOMFORWARD -d 224.0.0.0/4 -j ACCEPT
        /sbin/iptables -t nat -A CUSTOMPOSTROUTING -o wan-1.8 -d 87.141.128.0/17 -j MASQUERADE

        /usr/bin/killall dhcpcd
        /sbin/ip link delete wan-1.8
fi
### END IPTV

### STARTaddto xtiface
if [ -e /usr/local/bin/launch-xtiface ]; then
    if [ ${1} == "network" -a ${2} == "up" ]; then
        /usr/local/bin/launch-xtiface --start 1
        /usr/local/bin/launch-xtiface --start 2
        /usr/local/bin/launch-xtiface --start 3
        /usr/local/bin/launch-xtiface --start 4
    fi
    if [ ${1} == "network" -a ${2} == "down" ]; then
        /usr/local/bin/launch-xtiface --stop 1
        /usr/local/bin/launch-xtiface --stop 2
        /usr/local/bin/launch-xtiface --stop 3
        /usr/local/bin/launch-xtiface --stop 4
    fi
fi
### ENDaddto xtiface


und die rc.event.loal war bestimmt nicht die einzige Datei, die zwischenzeitlich eine Änderung erfahren hatte ...


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 9 Beiträge ] 

Alle Zeiten sind UTC+02:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu Forum:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de