IPCop-Forum.de

www.ipcop-forum.de


IPCop-Community
CL-Systems
Home Home   Doku Doku   Links Links   Downloads Downloads
UnIPCop Der (Un)IPCop   IFS IPCop-ForumSpy
CopTime CopTime   Galerie IPCop-Galerie   IPCop Userkarte Userkarte
Aktuelle Zeit: 19.04.2018, 13:24

Alle Zeiten sind UTC+02:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 5 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: OPENVPN
BeitragVerfasst: 01.07.2016, 17:25 
Offline
Apprentice
Themenstarter
Apprentice

Registriert: 17.06.2004
Beiträge: 15
Hallo zusammen,

ich hab den IPCop 2.1.9 installiert und verwende schon seit Monaten OpenVPN. Hatte nie Probleme.
Seit heute ohne das ich was verwendet habe kann ich keine Verbindung mehr zum IPcop aufbauen.

Der Log auf der Client Seite sieht wie folgt aus:
Fri Jul 01 17:16:25 2016 us=473914 MANAGEMENT: >STATE:1467386185,WAIT,,,
Fri Jul 01 17:17:25 2016 us=137867 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Fri Jul 01 17:17:25 2016 us=137867 TLS Error: TLS handshake failed
Fri Jul 01 17:17:25 2016 us=137867 TCP/UDP: Closing socket
Fri Jul 01 17:17:25 2016 us=137867 SIGUSR1[soft,tls-error] received, process restarting
Fri Jul 01 17:17:25 2016 us=137867 MANAGEMENT: >STATE:1467386245,RECONNECTING,tls-error,,
Fri Jul 01 17:17:25 2016 us=137867 Restart pause, 2 second(s)
Fri Jul 01 17:17:27 2016 us=141189 LZO compression initialized
Fri Jul 01 17:17:27 2016 us=141189 WARNING: normally if you use --mssfix and/or --fragment, you should also set --tun-mtu 1500 (currently it is 1400)
Fri Jul 01 17:17:27 2016 us=141189 Control Channel MTU parms [ L:1442 D:1212 EF:38 EB:0 ET:0 EL:3 ]
Fri Jul 01 17:17:27 2016 us=141189 Socket Buffers: R=[65536->65536] S=[65536->65536]
Fri Jul 01 17:17:27 2016 us=141189 MANAGEMENT: >STATE:1467386247,RESOLVE,,,
Fri Jul 01 17:17:27 2016 us=266163 Data Channel MTU parms [ L:1442 D:1442 EF:42 EB:143 ET:0 EL:3 AF:3/1 ]
Fri Jul 01 17:17:27 2016 us=266163 Local Options String: 'V4,dev-type tun,link-mtu 1442,tun-mtu 1400,proto UDPv4,comp-lzo,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-client'
Fri Jul 01 17:17:27 2016 us=266163 Expected Remote Options String: 'V4,dev-type tun,link-mtu 1442,tun-mtu 1400,proto UDPv4,comp-lzo,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-server'
Fri Jul 01 17:17:27 2016 us=266163 Local Options hash (VER=V4): 'a6ae7d69'
Fri Jul 01 17:17:27 2016 us=266163 Expected Remote Options hash (VER=V4): '006a55ce'
Fri Jul 01 17:17:27 2016 us=266163 UDPv4 link local (bound): [undef]
Fri Jul 01 17:17:27 2016 us=266163 UDPv4 link remote: [AF_INET]7x.xx5.xx7.17x:1194
Fri Jul 01 17:17:27 2016 us=266163 MANAGEMENT: >STATE:1467386247,WAIT,,,

Auf der Server Seite:
17:10:03 openvpnserver[2047] Initialization Sequence Completed
17:10:03 openvpnserver[2047] IFCONFIG POOL: base=10.1xx.1xx.4 size=62, ipv6=0
17:10:03 openvpnserver[2047] MULTI: multi_init called, r=256 v=256
17:10:03 openvpnserver[2047] UDPv4 link remote: [undef]
17:10:03 openvpnserver[2047] UDPv4 link local (bound): [undef]
17:10:03 openvpnserver[2047] UID set to nobody
17:10:03 openvpnserver[2047] GID set to nobody
17:10:03 openvpnserver[2043] /sbin/ip route add 10.1xx.1xx.0/24 via 10.1xx.1xx.2
17:10:03 openvpnserver[2043] /sbin/ip addr add dev tun0 local 10.1xx.1xx.1 peer 10.1xx.1xx.2
17:10:03 openvpnserver[2043] /sbin/ip link set dev tun0 up mtu 1400
17:10:03 openvpnserver[2043] do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
17:10:03 openvpnserver[2043] TUN/TAP TX queue length set to 100
17:10:03 openvpnserver[2043] TUN/TAP device tun0 opened
17:10:03 openvpnserver[2043] ROUTE_GATEWAY 1x.xxx.18.1/255.255.255.0 IFACE=wan-1 HWADDR=00:xx:xx:81:xx:c8
17:10:03 openvpnserver[2043] Socket Buffers: R=[163840->131072] S=[163840->131072]
17:10:03 openvpnserver[2043] WARNING: normally if you use --mssfix and/or --fragment, you should also set --tun-mtu 1500 (currently it is 1400)
17:10:03 openvpnserver[2043] WARNING: file '/var/ipcop/certs/hostkey.pem' is group or others accessible
17:10:03 openvpnserver[2043] Diffie-Hellman initialized with 1024 bit key
17:10:03 openvpnserver[2043] NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
17:10:03 openvpnserver[2043] library versions: OpenSSL 1.0.1k 8 Jan 2015, LZO 2.06
17:10:03 openvpnserver[2043] OpenVPN 2.3.6 i686-pc-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Dec 01 2014
17:09:44 openvpnserver[1354] SIGTERM[hard,] received, process exiting
17:09:44 openvpnserver[1354] Linux ip addr del failed: external program exited with error status: 2
17:09:44 openvpnserver[1354] /sbin/ip addr del dev tun0 local 10.1xx.1xx.1 peer 10.1xx.1xx.2
17:09:44 openvpnserver[1354] Closing TUN/TAP interface
17:09:44 openvpnserver[1354] ERROR: Linux route delete command failed: external program exited with error status: 2
17:09:44 openvpnserver[1354] /sbin/ip route del 10.1xx.1xx.0/24
17:09:44 openvpnserver[1354] TCP/UDP: Closing socket
17:09:44 openvpnserver[1354] event_wait : Interrupted system call (code=4)


Hatte jemand einen Tipp für mich, hab langsahm keine Idee mehr.

THX


Nach oben
   
 Betreff des Beitrags: Re: OPENVPN
BeitragVerfasst: 01.07.2016, 18:22 
Offline
Site-Moderator
Site-Moderator
Benutzeravatar

Registriert: 18.12.2007
Beiträge: 3328
Wohnort: Im Norden bei mir zu Hause
Was steht zum fraglichen Zeitpuntk im Firewallprotokoll? Ist ggfs. vor dem Cop noch ein Router installiert?

_________________
Gruß edelweis

Sledgehammer engineering, if it doesn't work, hammer it damn hard :super:

Bild
Bild
Meine Vorstellung


Nach oben
   
 Betreff des Beitrags: Re: OPENVPN
BeitragVerfasst: 01.07.2016, 18:50 
Offline
Apprentice
Themenstarter
Apprentice

Registriert: 17.06.2004
Beiträge: 15
Im Firewall log steht nicht´s ja vor dem IPcop ist ein Router der den Port 443 UDP an den Ipcop weiterleitet.
Aber wie gesagt ich habe habe nichts geändert.

Was neu ist im IPcop OpenVPN Log:
ERROR: Linux route delete command failed: external program exited with error status: 2
event_wait : Interrupted system call (code=4)

Diesen Fehle hatte ich noch nie.
Ich habe versucht eine Verbindung von zwei unterschiedlichen PC´s aufzubauen immer mit dem selben Fehler auf der Client Seite.
Die PC´s stehen auch in unterschiedlichen Netzwerken daher kann ich den Client ausschliessen.


Nach oben
   
 Betreff des Beitrags: Re: OPENVPN
BeitragVerfasst: 01.07.2016, 18:54 
Offline
Site-Moderator
Site-Moderator
Benutzeravatar

Registriert: 18.12.2007
Beiträge: 3328
Wohnort: Im Norden bei mir zu Hause
mike2709 hat geschrieben:
Im Firewall log steht nicht´s ja vor dem IPcop ist ein Router der den Port 443 UDP an den Ipcop weiterleitet.
OpenVPN läuft aber nicht auf Port 443, sondern auf Port 1194, wie bei dir auch in den LOGs zu sehen ist.

_________________
Gruß edelweis

Sledgehammer engineering, if it doesn't work, hammer it damn hard :super:

Bild
Bild
Meine Vorstellung


Nach oben
   
 Betreff des Beitrags: Re: OPENVPN
BeitragVerfasst: 01.07.2016, 18:59 
Offline
Apprentice
Themenstarter
Apprentice

Registriert: 17.06.2004
Beiträge: 15
Danke für deine unterstützung geht wieder.
Hab den Speedport neu gestartet.


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 5 Beiträge ] 

Alle Zeiten sind UTC+02:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu Forum:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de